Service not run

Mar 3, 2009 at 2:27 PM
Hi all

I don't succeded to run the tsf deployer tools. I think that the issue is the Base address because I can't understand to use this setting

The configuration is :

      <setting name="ToAddress" serializeAs="String">
      <setting name="BaseAddress" serializeAs="String">
      <setting name="RegistrationUserName" serializeAs="String">
      <setting name="TeamFoundationServerUrl" serializeAs="String">
      <setting name="UseDefaultCredentials" serializeAs="String">
      <messageLogging logEntireMessage="true" />
      <add name="Readify.Useful.TeamFoundation.Common" value="2" />
      <add name="TfsDeployer" value="2" />
    <trace autoflush="true">
        <add initializeData="TfsDeployer" type="System.Diagnostics.EventLogTraceListener" name="Logger" traceOutputOptions="Callstack" />
      <setting name="FromAddress" serializeAs="String">
      <setting name="SmtpServer" serializeAs="String">

Jul 21, 2010 at 1:40 PM

Same here using the newest Version to work with TFS2010.

Want to test TFSDeploy local on my Notebook.

<?xml version="1.0"?>
    <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089">
      <section name="TfsDeployer.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
      <setting name="KeyFile" serializeAs="String">
        <value />
      <setting name="SignDeploymentMappingFile" serializeAs="String">
      <setting name="TfsUserName" serializeAs="String">
      <setting name="TfsDomain" serializeAs="String">
      <setting name="TfsPassword" serializeAs="String">
      <setting name="TeamProjectCollectionUri" serializeAs="String">
      <setting name="BaseAddress" serializeAs="String">
      <!-- TODO update mail settings for each environment -->
      <smtp deliveryMethod="Network" from="me@localhost" >
        <network host="localhost" defaultCredentials="true" />

    <!-- Uncomment the switches section to increase trace verbosity -->
      <add name="Readify.Useful.TeamFoundation.Common" value="Verbose" />
      <add name="TfsDeployer" value="Verbose" />
      <add name="TfsDeployer.DeployAgent.DeploymentHostUI" value="Verbose" />
    <trace autoflush="true" />



Do you have any Hints or Tipps?

Jul 21, 2010 at 11:47 PM
Have you tried running the Test-TfsDeployerInstall.ps1 script in the TFS Deployer folder? What output did you see?
Jul 26, 2010 at 11:44 AM

i don't get a "Test successfull" - 'm getting this Error:


PS C:\Users\klappi\Desktop\TfsDeployer> .\Test-TfsDeployerInstall.ps1
TfsDeployer service path to executable should be: C:\Users\klappi\Desktop\Tf
Bei C:\Users\klappi\Desktop\TfsDeployer\Test-TfsDeployerInstall.ps1:25 Zeich
+     throw <<<<  "TfsDeployer service path to executable should be: $QuotedExe
    + CategoryInfo          : OperationStopped: (TfsDeployer ser...TfsDeployer
   .exe:String) [], RuntimeException
    + FullyQualifiedErrorId : TfsDeployer service path to executable should be
   : C:\Users\klappi\Desktop\TfsDeployer\TfsDeployer.exe

PS C:\Users\klappi\Desktop\TfsDeployer>

Jul 27, 2010 at 1:36 PM
Check in which folder located executables for the TFS Deployer service. Place the script to the same folder.
Jul 27, 2010 at 4:10 PM
its in the same Directroy. I think that "$PSScriptRoot = $MyInvocation.MyCommand.Path | Split-Path -Resolve" doesnt work correct. Thats because i get this error and thats why i cant test the test script. i've Uploaded a Screenshot of it: anything i can do?
Jul 28, 2010 at 10:38 AM
Try to find TFS Deployer service on Control Panel->Administrative Tools->Services and check path to executable in service properties. Also you can run this script in PowerShell_ISE (located in the same folder as PowerShell.exe), set break point on this string and check variables values.
Jul 28, 2010 at 3:04 PM
Edited Jul 28, 2010 at 3:08 PM

Thanks for your Reply.

Now i've gone a step forward :)

1. i've installed the .MSI from

2. updated the installation with the actual Version for TFS2010

3. Now i could execute the Test-TfsDeployerInstall.ps1, but it seems that my User/Pass are incorrect! I've uploaded two images which show what happened: 

If i start the Service manually i won't work, the Services ends directly after it is startet. Is there a Mode to get further information?




My Constellation: Notebook (Domain A) <> TFS-Server (Domain B) i am testing with my Notebook. Is it possible that this causes the error? Should it work if i installe the Service directly on my Buildserver on Domain B?
Jul 28, 2010 at 4:42 PM

Go to Control Panel->Administrative Tools->Local Security Policy->Local Policies->User Rights Assignment and check the "Log on as service" policy. Your user must be added to this policy.

Jul 29, 2010 at 8:51 AM

My User (Domain\Administrator) is in that List.

Jul 30, 2010 at 3:50 AM

Hi klappi,

I suspect you have encountered a limitation of the Test-TfsDeployerInstall script that I hadn't anticipated. I believe your TFS Deployer service is configured to logon with the username "administrator@yourdomain.etc" but the test script is expecting it in the format "YourDomain\Administrator".

I plan to fix this bug in the test script, but in the mean-time, if possible, configure the service account using the latter username format instead and retry the script.



Jul 30, 2010 at 10:11 AM

thanks! Thats it!

Now i've the next Problem :) - i can't access to TFS. I thinks its because my Notebook is in DomainA and the TFS-Server is in DomainB. Is it right, that the Test-Script connects with the Service Credentials to the TFS? Thats what i see in the Logs on TFS-Server.

I think that i've read, that the Service Account will only used to connect if i don't configure in tfsdeployer.config?



Oct 14, 2010 at 11:27 AM
Edited Oct 14, 2010 at 1:33 PM

EDIT: Sorry. My issue was a misunderstanding of the Old and New Build Quality parameters. The world has meaning again.


I'm also having problems getting the scripts to run. Test-TfsDeployerInstall seems to work fine. Running TfsDeployer -d in the command line with diagnostic switches enabled shows that the builds events and mappings correspond, but there is no result from my script and no errors displayed. I've tried a both batch files and powershell scripts but they don't seem to get executed.

Any clues?